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 Important Information

Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects 
in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National 
Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives 
notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be 
uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any 
equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by 
warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In 
the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document 
without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. In no event shall National 
Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL 
INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING 
FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of 
the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against 
National Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in 
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service 
failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the 
product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside 
reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, 
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National 
Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other 
intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only 
to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

BSIM3 and BSIM4 are developed by the Device Research Group of the Department of Electrical Engineering and Computer Science, University of 
California, Berkeley and copyrighted by the University of California. 

The ASM51 cross assembler bundled with Multisim MCU is a copyrighted product of MetaLink Corp. (www.metaice.com). 

MPASM™ macro assembler and related documentation and literature is reproduced and distributed by Electronics Workbench under license from 
Microchip Technology Inc.  All rights reserved by Microchip Technology Inc.  MICROCHIP SOFTWARE OR FIRMWARE AND LITERATURE 
IS PROVIDED “AS IS,” WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE 
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL 
MICROCHIP BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY ARISING OUT OF OR IN CONNECTION WITH THE 
SOFTWARE OR FIRMWARE OR THE USE OF OTHER DEALINGS IN THE SOFTWARE OR FIRMWARE.

Trademarks
National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section 
on ni.com/legal for more information about National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, 
partnership, or joint-venture relationship with National Instruments.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file 
on your CD, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF 
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN 
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT 
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE 
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, 
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS 
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE 
COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, 
TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR 
ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER 
COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF 
HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY 
UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, 



THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES, 
INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS 
CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION 
DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT 
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY 
RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER 
NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT 
LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.
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1
NI Multisim Analog Devices 
Edition Tutorial

This chapter contains a tutorial that introduces you to Multisim and its 
many functions. 

Overview 
This tutorial leads you through the circuit design flow, from schematic 
capture, through simulation and analysis. After following the steps outlined 
on the following pages, you will have designed a circuit that samples a 
small analog signal, amplifies it and then counts the occurrences of the 
signal on a simple digital counter. 

Helpful tips are indicated by the presence of an icon in the left column, as in 
the following example: 

Tip You can access the online help at any time by pressing F1 on your keyboard, or by 
clicking on the Help button in a dialog box. 

When you get to the wiring section of this tutorial, you can carry on with 
the circuit you created in the component placement section, or open the file 
Getting Started 1.ms10 (which has all components properly placed) 
from the Getting Started folder (found inside the samples folder) and 
proceed. When you arrive at the simulation section, you can carry on with 
the circuit you wired, or open the file Getting Started 2.ms10 (which 
has all components properly wired). 
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Schematic Capture 
In this section, you will place and wire the components in the circuit shown 
below. 

Opening and Saving the File 
To launch Multisim: 

1. Select Start»All Programs»National Instruments»Multisim 
Analog Devices Edition 10.0»Multisim Analog Devices Edition. A 
blank file opens on the workspace called Circuit1. 

To save the file with a new name: 

1. Select File»Save As to display a standard Windows Save dialog.

2. Navigate to the location where you wish the file to reside, enter 
MyGettingStarted as the filename, and click the Save button.
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Tip To guard against accidental loss of data, set up a timed auto-backup of the file in the 
Save tab of the Preferences dialog box. 

To open an existing file: 

1. Select File»Open, navigate to the location where the file resides, 
highlight the file, and click on the Open button. 

Placing the Components 
To start placing components: 

1. Open MyGettingStarted.ms10 as described above. 

2. Select Place»Component to display the Select a Component 
browser, navigate to the 7-segment LED display as shown below and 
click OK. The component appears as a “ghost” on the cursor. 

Tip Once you have selected the desired Group and Family, start typing the component’s 
name in the browser’s Component field. As you type, the string appears in the 
Searching field at the bottom of the browser. In the example below, type 
“seven_seg_decimal_com_a_blue”. Matches are displayed as you type. 
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3. Move the cursor to the bottom-right of the workspace and left-click to 
place the component. Note that the Reference Designator for this 
component is “U1”. 

4. Place the remaining components in the Digital Counter area as shown 
below. 

 

Note When placing resistors, inductors, or capacitors (RLC components), the Select a 
Component browser has slightly different fields than for other components. When placing 
any of these components, you can choose any combination of: the component’s value (for 
example, the resistance value); type (for example, carbon film); tolerance; footprint and 
manufacturer. If you are placing a component that will be ultimately exported to PCB 
layout, and become part of a Bill of Materials, you must be careful that the combination 
of values that you select in the Select a Component dialog box are available in a 
real-world, purchaseable component. 

Tip When placing RLC components, type the value of the device that you want to place 
in the field at the top of the Component list. The value does not need to appear in the list 
to be placed on the schematic. 

Tip While placing the 200-ohm resistor, rotate it to a vertical orientation by pressing 
<Ctrl-R> on your keyboard. 
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Tip Reference Designators (for example, U1, U2) are assigned in the order the 
components are placed. If you place components in a different order than in the original 
circuit, the numbering will differ. This will not affect the operation of the circuit in any way. 

5. Place the parts in the Counter Control section. After placement, 
right-click on each of the SPDT switches and select Flip Horizontal.

 

Tip When a part is on the workspace and you want to place the same part again, highlight 
it and select Edit»Copy, then Edit»Paste. You can also select it from the In Use List and 
click to place it on the workspace. 

6. Place the parts in the Analog Amplifier section as shown below, 
rotating as needed.

 

The SPDT switches are in the Basic 
Group; Switch Family
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After you place the AC voltage signal source, double-click on it. 
Change the Voltage (Pk) to 0.2 V and click OK to close the dialog.

7. Place the parts in the Bypass Capacitors section as shown below. 
 

8. Place the header and associated parts as shown below.

Tip Once you have wired a circuit, you can drop two-pinned passive components like 
resistors directly onto a wire. The connection is automatically made by Multisim. 

Wiring the Circuit 
All components have pins that you use to wire them to other components 
or instruments. As soon as your cursor is over a pin, Multisim knows you 
want to wire and the pointer changes to a crosshair. 

Tip You can wire the circuit that you placed on the workspace or you can use 
Getting Started 1.ms10 from the Getting Started folder (found inside the 
samples folder). 

J3 is in the Basic Group; 
Connectors Family
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To wire the circuit: 

1. Click on a pin on a component to start the connection (your pointer 
turns into a crosshair) and move the mouse. A wire appears, attached 
to your cursor. 

2. Click on a pin on the second component to finish the connection. 
Multisim automatically places the wire, which conveniently snaps to 
an appropriate configuration, as shown below. This feature saves a 
great deal of time when wiring large circuits. 

 

3. You can also control the flow of the wire by clicking on points as you 
move the mouse. Each click “fixes” the wire to that point. 

4. Finish wiring the Digital Counter section as shown below. 
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Tip Use Bus Vector Connect to wire multi-pinned devices like U3 and R4 together. Refer 
to the Multisim User Guide for details. 

Tip Virtual Wiring—To avoid clutter, you could use virtual connections between the 
Counter Control and Digital Counter sections. When two nets have the same net name, they 
are virtually connected. 

5. Finish wiring the circuit as shown below. 
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Simulation 
Simulating your circuits with Multisim catches errors early in the design 
flow, saving time and money. 

Virtual Instrumentation 
In this section, you will simulate the circuit with the virtual oscilloscope. 

Tip You can also use Getting Started 2.ms10 from the Getting Started folder 
(found inside the samples folder). 

1. J1, J2 and R2 are interactive components. 

Set up the interactive keys for J1, J2 and R2 by double-clicking on 
each. In the Key field, enter “E” for J1, “L” for J2, and “A” for R2. 

Press “E” to enable the counter, or just click on the widened switch arm 
that appears when you hover the cursor over J1. 

2. Select Simulate»Instruments»Oscilloscope to place the oscilloscope 
on the workspace. Wire the instrument as shown in step 4. 
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Tip To easily differentiate between traces on the oscilloscope, right-click on the wire 
connected to the scope’s “B” input and select Segment Color from the pop-up. Select a 
color that differs from the wire connected to the “A” input, for example blue. (Simulation 
cannot be running when changing wire color or performing any other editing function).

3. Double-click on the scope’s icon to show the instrument face. Select 
Simulate»Run. The output of the opamp appears on the scope.  

4. Adjust the Timebase to 2mS/Div and Channel A’s Scale to 
500mV/Div. You will see the following displayed on the scope.

 

As the circuit simulates, the 7-segment display counts up and the LED 
flashes at the end of each count cycle. 

5. Press “E” on your keyboard while the simulation is running to enable 
or disable the counter. Enable is Active Low. 

Press “L” to load zeros into the counter. Load is Active Low. 

Press “Shift-A” to observe the effect of changing the potentiometer’s 
setting. Repeat, pressing “A”. 

Tip Instead of pressing the above-mentioned keys, you can directly manipulate the 
interactive components on the schematic with your mouse. 
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Analysis 
In this section, you will use AC Analysis to verify the frequency response 
of the amplifier. 

To perform an AC Analysis at the output of the opamp: 

1. Double-click on the wire that is attached to pin 6 of the opamp, and 
change the net name to analog_out in the Net dialog box. 

2. Select Simulate»Analyses»AC Analysis and click on the Output tab.
 

3. Highlight V(analog_out) in the left column and click Add. 
V(analog_out) moves to the right column. 

4. Click Simulate. The results of the analysis appear in the Grapher. 
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The Grapher 
The Grapher is a multi-purpose display tool that lets you view, adjust, save 
and export graphs and charts. It is used to display the results of all Multisim 
analyses in graphs and charts and a graph of traces for some instruments 
(for example the results of the oscilloscope). 

To view results of a simulation on the Grapher: 

1. Run the simulation as described earlier. 

2. Select View»Grapher.
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The Postprocessor 
Use the Postprocessor to manipulate the output from analyses performed 
on a circuit and plot the results on a graph or chart. Types of mathematical 
operations that can be performed on analysis results include arithmetic, 
trigonometric, exponential, logarithmic, complex, vector and logic. 

Reports 
Multisim allows you to generate a number of reports: Bill of Materials 
(BOM), Component Detail Report, Netlist Report, Schematic Statistics, 
Spare Gates and the Cross Reference Report. This section uses the BOM 
as an example for the tutorial circuit. 

Bill of Materials 
A bill of materials lists the components used in your design and therefore 
provides a summary of the components needed to manufacture the circuit 
board. Information provided includes: 

• quantity of each component needed 

• description, including the type of part (example: resistor) and value 
(example: 5.1 kohm) 
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• Reference Designator of each component 

• package or footprint of each component 

To create a BOM (bill of materials) for your circuit: 

1. Click the Reports menu and choose Bill of Materials from the menu 
that appears. 

2. The report appears, looking similar to this:

To print the Bill of Materials, click the Print button. A standard Windows 
print screen appears, allowing you to choose the printer, number of copies, 
and so on.  

To save the Bill of Materials to a file, click the Save button. A standard 
Windows file save dialog box appears, allowing you to specify the path and 
file name. 

Because the Bill of Materials is primarily intended to assist in procurement 
and manufacturing, it includes only “real” parts—it excludes parts that are 
not real or able to be purchased, such as sources or virtual components. 

To see a list of components in your circuit that are not “real” components, 
click the Virtual button. A separate window appears, showing these 
components only.  
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Detailed information on this and other reports can be found in the 
Multisim User Guide. 
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For answers and solutions, visit the 
award-winning National Instruments Web site for software drivers 
and updates, a searchable KnowledgeBase, product manuals, 
step-by-step troubleshooting wizards, thousands of example 
programs, tutorials, application notes, instrument drivers, and 
so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Discussion Forums at 
ni.com/forums. National Instruments Application Engineers 
make sure every question receives an answer.

For information about other technical support options in your 
area, visit ni.com/services or contact your local office at 
ni.com/contact. 

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance. 

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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